Vue 3.0 beta 了!

从年前到现在,终于出beta版本了。来看看官方详情是怎么说的?

状态:测试版

  • 所有计划中的RFC都已合并。
  • 所有合并后的 RFC 都已实现。
  • Vue CLI 现在通过 vue-CLI-plugin-vue-next 提供了实验性支持。
  • 这里还有一个简单的基于 Webpack 的简单设置,支持单文件组件。
请注意,在2.x版本中仍然可能存在未被记录的行为不一致的情况。如果不一致的行为不属于RFC的一部分,那么很可能是无意的,需要新建一个issue(新建一个issue时请务必使用issue帮助器)。 此外,目前的实现需要在运行时环境中使用原生的ES2015+,不支持IE11(还没有)。IE11兼容的构建将在我们达到RC阶段后再进行。

官方库Vue 3支持状态

说明:

从官网中可以看到大部分主要的插件都有相关的版本了,但小右说了,暂时还不建议升级生产环境应用,升级指南和配套工具都还没完善,但是可以在新项目或者小项目里试用 了解更多可以看前文:迎接 Vue 3.0